updated udev, kernel and checked in tetex changes
[hdw-linux/hdw-linux.git] / packages / hackbard / tetex / tetex
index 6d3d661..880edf9 100644 (file)
@@ -2,46 +2,36 @@
 #
 # author: hackbard@hackdaworld.dyndns.org
 #
-# [V] 2.0.2
+# [V] 3.0
 # [S] 3-5
-# [D] tetex-src-2.0.2.tar.gz ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/2.0/distrib/
-# [D] tetex-texmf-2.0.2.tar.gz ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/2.0/distrib/
-# [D] tetex-texmfsrc-2.0.2.tar.gz ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/2.0/distrib/
-# [D] graphs.tar.gz http://www.cs.umu.se/~drewes/graphs/
+# [D] tetex-src-3.0.tar.gz ftp://tug.ctan.org/tex-archive/systems/unix/teTeX/3.0/distrib/
+# [D] tetex-texmf-3.0.tar.gz ftp://tug.ctan.org/tex-archive/systems/unix/teTeX/3.0/distrib/
+# [D] tetex-texmfsrc-3.0.tar.gz ftp://tug.ctan.org/tex-archive/systems/unix/teTeX/3.0/distrib/
+# [D] pdfcprot.dtx http://www.ctan.org/tex-archive/macros/latex2e/contrib/pdfcprot/
+# [D] pdfcprot.ins http://www.ctan.org/tex-archive/macros/latex2e/contrib/pdfcprot/
 
 srcdir="tetex-src-$ver"
-confopt="$confopt --disable-multiplatform"
+confopt="$confopt --with-system-ncurses --with-system-zlib"
+confopt="$confopt --exec-prefix=$prefix --without-texinfo"
+# to avoid x dependency
+# confopt="$confopt --with-x=no"
+
+make_conf="all $make_conf"
 
 pre_install()  {
-       mkdir -p $prefix/share/texmf
-       mkdir -p $root/src.$package/tex
-       tar --use-compress-program=gunzip -xf \
-               $archdir/tetex-texmf-${ver}.tar.gz -C \
-               $root/src.$package/tex
-       chown -R 0.0 $root/src.$package/tex
-       cp -a $root/src.$package/tex/* $prefix/share/texmf
-       rm -rf $root/src.$package/tex/*
-       tar --use-compress-program=gunzip -xf \
-               $archdir/tetex-texmfsrc-${ver}.tar.gz -C \
-               $root/src.$package/tex
-       chown -R 0.0 $root/src.$package/tex
-       cp -a $root/src.$package/tex/* $prefix/share/texmf
-       rm -rf $root/src.$package/tex
-       
-       # wrong timestamp
-       #touch ./texk/web2c/tangleboot.p
-       # new flex
-       sed 's%$(LEX)%$(LEX) -l%g' texk/web2c/omegafonts/Makefile.in > tmp~
-       mv tmp~ texk/web2c/omegafonts/Makefile.in
+       install -v -d -m755 $prefix/share/texmf
+       gzip -dc $archdir/tetex-texmf-${ver}.tar.gz | \
+               ( umask 0; tar -C $prefix/share/texmf -xf -)
+       gzip -dc $archdir/tetex-texmfsrc-${ver}.tar.gz | \
+               ( umask 0; tar -C $prefix/share/texmf -xf -)
                }
 
 post_install() {
-       # installing graphs.sty
-       mkdir -p $prefix/share/texmf/tex/latex/graphs
-       tar --use-compress-program=gunzip -xf \
-               $archdir/graphs.tar.gz -C \
-               $prefix/share/texmf/tex/latex/graphs
-       chown -R 0.0 $prefix/share/texmf/tex/latex/graphs
-       echo "\special{header=${prefix}/share/texmf/tex/latex/graphs/graphs.header}" > \
-               $prefix/share/texmf/tex/latex/graphs/graphs_config.tex
+       install -v -d -m755 $prefix/share/texmf/tex/latex/pdfcprot
+       mkdir pdfcprot && cd pdfcprot
+       cp $archdir/pdfcprot.* 
+       latex pdfcprot.ins
+       cp * $prefix/share/texmf/tex/latex/pdfcprot/
+       cd ..
+       texhash
                }