toolchain modoifications
[hdw-linux/hdw-linux.git] / packages / toolchain / gcc / gcc
index 71ed73b..128d8d0 100644 (file)
@@ -17,7 +17,7 @@ if [ "$priority" = "1" ] ; then
        confopt="$confopt --enable-languages=c --disable-nls"
 
        post_install()  {
-               ln -sf gcc $prefix/bin/cc
+               ln -vsf gcc $prefix/bin/cc
                        }
 fi
 
@@ -28,6 +28,14 @@ if [ "$priority" = "4" ] ; then
        make_conf=""
 
        pre_install()   {
+               # no fix includes
+               echo "patching (no fixincludes)"
+               sed -e 's@\./fixinc\.sh@-c true@' \
+                   -e 's@^XCFLAGS =$@/& -fomit-frame-pointer@' \
+                        gcc/Makefile.in > tmp~
+               mv tmp~ gcc/Makefile.in
+
+               # specs
                echo "patching gcc specs now"
                for i in gcc/config/*/{pa-,}linux*.h; do
                        echo "patching $i ..."
@@ -52,9 +60,6 @@ if [ "$priority" = "4" ] ; then
                echo "patching gcc/config/linux.h ..."
                echo "#undef STANDARD_INCLUDE_DIR" >> gcc/config/linux.h
                echo "#define STANDARD_INCLUDE_DIR 0" >> gcc/config/linux.h
-               # no fix includes
-       [ -f $hdw_home_dir/packages/base/gcc/no_fix_includes.patch ] && \
-       patch -Nfp1 < $hdw_home_dir/packages/base/gcc/no_fix_includes.patch
                        }
 fi