toolchain modoifications
[hdw-linux/hdw-linux.git] / packages / toolchain / gcc / gcc
index 8193ae2..128d8d0 100644 (file)
@@ -2,9 +2,9 @@
 #
 # author: hackbard@hackdaworld.dyndns.org
 #
-# [V] 4.0.0
+# [V] 4.1.1
 # [S] 0-1 0-4
-# [D] gcc-4.0.0.tar.bz2 ftp://ftp.fu-berlin.de/unix/gnu/gcc/gcc-4.0.0/
+# [D] gcc-4.1.1.tar.bz2 ftp://ftp.fu-berlin.de/unix/gnu/gcc/gcc-4.1.1/
 
 
 extraver="-$ver"
@@ -13,18 +13,11 @@ extraver="-$ver"
 confopt="$confopt --enable-shared --with-local-prefix=$prefix"
 confopt="$confopt --libexecdir=$prefix/lib"
 
-unset CFLAGS
-
 if [ "$priority" = "1" ] ; then
        confopt="$confopt --enable-languages=c --disable-nls"
 
-       # use host system tools
-       hdw_arch_prefix="" ; hdw_cflags=""
-       . ./scripts/optimization
-       unset CFLAGS
-
        post_install()  {
-               ln -sf gcc $prefix/bin/cc
+               ln -vsf gcc $prefix/bin/cc
                        }
 fi
 
@@ -35,6 +28,14 @@ if [ "$priority" = "4" ] ; then
        make_conf=""
 
        pre_install()   {
+               # no fix includes
+               echo "patching (no fixincludes)"
+               sed -e 's@\./fixinc\.sh@-c true@' \
+                   -e 's@^XCFLAGS =$@/& -fomit-frame-pointer@' \
+                        gcc/Makefile.in > tmp~
+               mv tmp~ gcc/Makefile.in
+
+               # specs
                echo "patching gcc specs now"
                for i in gcc/config/*/{pa-,}linux*.h; do
                        echo "patching $i ..."
@@ -59,9 +60,6 @@ if [ "$priority" = "4" ] ; then
                echo "patching gcc/config/linux.h ..."
                echo "#undef STANDARD_INCLUDE_DIR" >> gcc/config/linux.h
                echo "#define STANDARD_INCLUDE_DIR 0" >> gcc/config/linux.h
-               # no fix includes
-       [ -f $hdw_home_dir/packages/base/gcc/no_fix_includes.patch ] && \
-       patch -Nfp1 < $hdw_home_dir/packages/base/gcc/no_fix_includes.patch
                        }
 fi