hopefully fixed firefox & thunderbird package
[hdw-linux/hdw-linux.git] / packages / x11 / thunderbird / thunderbird
index 13b3e0b..08478cb 100644 (file)
@@ -2,13 +2,16 @@
 #
 # author: hackbard@hackdaworld.dyndns.org
 #
-# [V] 1.0.6
+# [V] 1.6a1
 # [S] 3-8
-# [D] thunderbird-1.0.6-source.tar.bz2 http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/1.0.6/source/
+# [D] mozilla-cvs-20050905_1800.tar.bz2 http://hdwlinux.org/download/hdw-linux/hdw-linux-1.0/sources/x11/thunderbird/
 
 srcdir=mozilla
 optimize="`echo $hdw_cflags | awk '{ print $1 }'`"
+extensions="wallet,spellcheck,xmlextras,webservices"
 export PKG_CONFIG_PATH="$prefix/X11R6/lib/pkgconfig"
+# firefox doesn't like optimization
+unset CFLAGS CPPFLAGS CXXFLAGS
 
 pre_install()  {
        export MOZILLA_OFFICIAL=1 BUILD_OFFICIAL=1 MOZ_THUNDERBIRD=1
@@ -16,10 +19,9 @@ pre_install()        {
        sed "s,0000000000,hdw-linux -- ${hdw_version}," \
                xpfe/global/build.dtd.in > xpfe/global/build.dtd.in.new
        mv xpfe/global/build.dtd.in.new xpfe/global/build.dtd.in
-       # patching app Makefile (still needed?)
-       sed 's/$(destdir)$(bindir)/$(DESTDIR)$(mozappdir)/' \
-               mail/app/Makefile.in > mail/app/Makefile.in.new
-       mv mail/app/Makefile.in.new mail/app/Makefile.in
+       sed -i 's|    dist_bin="$moz_libdir"|\
+                       &\n    run_moz="$dist_bin/run-mozilla.sh"|' \
+                       browser/app/mozilla.in
                }
 
 confopt="$confopt --enable-default-toolkit=gtk2 --with-x --with-system-zlib"
@@ -27,11 +29,14 @@ confopt="$confopt --with-system-jpeg --with-system-png"
 confopt="$confopt --with-default-mozilla-five-home=$MOZILLA_FIVE_HOME"
 confopt="$confopt --enable-xft --enable-crypto --enable-xinerama"
 confopt="$confopt --enable-application=mail --enable-strip --enable-strip-libs"
-confopt="$confopt --enable-reorder --enable-cpp-rtti --enable-extensions=all"
-confopt="$confopt --disable-tests --disable-debug --disable-extensions"
+confopt="$confopt --enable-reorder --enable-cpp-rtti"
+confopt="$confopt --enable-extensions=$extensions" 'all' or '$extensions'
+confopt="$confopt --disable-tests --disable-debug"
 confopt="$confopt --disable-pedantic --disable-logging --disable-accessibility"
 confopt="$confopt --disable-freetype2 --disable-installer --disable-mathml"
 confopt="$confopt --disable-profilesharing --enable-single-profile"
+confopt="$confopt --enable-necko-protocols=http,file,jar,viewsource,res,data"
+confopt="$confopt --enable-image-decoders=default,-xbm"
 confopt="$confopt --disable-oji --disable-plugins --disable-necko-disk-cache"
 confopt="$confopt --enable-optimize='$optimize'"
 
@@ -39,11 +44,17 @@ post_install()      {
        install -d $prefix/include/thunderbird-$ver/nss
        cp -vLf dist/private/nss/*.h dist/public/nss/*.h \
                $prefix/include/thunderbird-$ver/nss
+       install -d $prefix/lib/thunderbird-$ver/defaults/isp/US
+       install mailnews/base/ispdata/movemail.rdf \
+               mail/extensions/newsblog/rss.rdf \
+               $prefix/lib/thunderbird-$ver/defaults/isp &&
+       ln -sfv ../{movemail,rss}.rdf \
+               $prefix/lib/thunderbird-$ver/defaults/isp/US
        ln -sfv thunderbird-$ver $prefix/lib/thunderbird
        ln -sfv thunderbird-$ver $prefix/include/thunderbird
 
        cd $prefix/lib/thunderbird-$ver
-       LD_LIBRARY_PATH=. ./regxpcom
-       LD_LIBRARY_PATH=. ./regchrome
+       [ -f ./regxpcom ] && LD_LIBRARY_PATH=. ./regxpcom
+       [ -f ./regchrome ] && LD_LIBRARY_PATH=. ./regchrome
        touch `find $PWD -name *.rdf`
                }